FibreGeeks - KeyWest - Service outage – Incident details

KeyWest - Service outage

Resolved
Major outage
Started 6 days agoLasted 25 minutes
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are currently investigating an issue with our Layer 2 connectivity to the estate, We have logged the issue with our backhaul provider and will provide feedback as soon as possible.