FibreGeeks - Service Outage (Degraded Performance): Glencrest, Glenwood and Eastglen – Incident details

Service Outage (Degraded Performance): Glencrest, Glenwood and Eastglen

Resolved
Degraded performance
Started 3 days agoLasted about 19 hours

Affected

Network Services

Operational from 9:42 AM to 10:40 AM, Degraded performance from 10:40 AM to 4:47 AM

Vredekloof

Operational from 9:42 AM to 10:40 AM, Degraded performance from 10:40 AM to 4:47 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Update
    Update

    Our backhaul provider is currently underway with repairs, they have provided us with an ETR of 06:00 (07/05/2025)

    Further Updates to follow as they become available.

  • Update
    Update

    Our backhaul provider has informed us of a break on the link to the estate affecting majority of the area. We don't have an ETA for repair at the moment, however we do know that the extent of the damage is quite severe.

    We do apologize for any inconvenience caused and will provide an update as soon as possible

  • Update
    Update

    Backhaul providers' technicians are still investigating further.

    No ETA has been provided yet.

  • Identified
    Identified

    Backhaul providers have dispatched technicians to investigate further.

  • Investigating
    Investigating

    We are currently experiencing a service outage affecting Glencrest, Glenwood, and Eastglen; the site is running on a backup link, therefore, do expect degraded performance.

    We are currently investigating the issue as it seems to be backhaul related and will provide an update as soon as possible.