Scheduled for May 13, 2026 at 11:00 PM – May 14, 2026 at 3:00 AM
Affects
Network Services
Under maintenance from 11:00 PM to 3:00 AM
Parklands
Under maintenance from 11:00 PM to 3:00 AM
Updates
Completed
May 14, 2026 at 3:00 AM
Completed
May 14, 2026 at 3:00 AM
Maintenance has completed successfully
In progress
May 13, 2026 at 11:00 PM
In progress
May 13, 2026 at 11:00 PM
Maintenance is now in progress
Planned
May 13, 2026 at 11:00 PM
Planned
May 13, 2026 at 11:00 PM
Please be advised that we will be conducting scheduled maintenance on our Sandown Node to improve network stability and reliability.
Areas that will be affected are: Sagewood, Sandown, Rivergate, Pioneer Valley, Pioneer Park, and Pioneer Place. Connectivity may be limited or nonexistent during this time.